Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 08, 2025 - 08:00 UTC
Scheduled
Dear merchant,
We would like to inform you of a scheduled maintenance that may affect card payment processing in Chile across our platform.
The maintenance window is scheduled as follows: • Start Time: Tuesday, July 8 at 08:00 AM UTC • End Time: Tuesday, July 8 at 08:40 AM UTC • Estimated Duration: 40 minutes
During this time, card processing services in Chile may experience intermittent disruptions.
We apologize for any inconvenience this may cause and appreciate your understanding as our provider performs these necessary updates.
If you have any questions or need assistance, feel free to reach out to our support team at support@rebill.com.
Posted Jul 07, 2025 - 21:11 UTC
This scheduled maintenance affected: Platform (Payment Service).