Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 10, 2026 - 09:00 UTC
Scheduled
We will be performing scheduled maintenance on Wednesday, June 10, between 09:00 and 11:00 UTC (06:00–08:00 UTC-3).
During this window, some services may be intermittently unavailable or experience degraded performance.
We have scheduled this maintenance during a low-traffic period to minimize any impact. We appreciate your understanding and apologize for any inconvenience.
If you have any questions or concerns, please feel free to contact us at support@rebill.com
Posted Jun 09, 2026 - 18:29 UTC
This scheduled maintenance affected: Platform (Payment Service, Subscriptions, Dashboard).