Resolved: Platform and payment processing downtime
Incident Report for Rebill.com
Resolved
We wish to inform you that our payment platform encountered a period of downtime, impacting login capabilities, tokenization and payment procesing between 14:36 and 15:40 UCT-3.

We are pleased to announce that the issue has now been fully resolved. We extend our sincerest apologies for any inconvenience this may have caused and appreciate your understanding.

Feel free to reach out to us support@rebill.com if you have any doubts regarding this issue.
Posted Mar 04, 2024 - 21:44 UTC
This incident affected: Platform (Payment Service, Subscriptions, Dashboard).