Resolved: Incident Report - Dashboard and API Performance Degradation
Incident Report for Rebill.com
Resolved
We experienced a performance degradation affecting our Dashboard and API from 7:00 AM to 10:26 AM (UTC-3). During this time, some users may have encountered slower response times or difficulty accessing these services.

The issue was caused by a failure in the automatic renewal of the SSL certificate for rebill.com, which is managed by AWS Certificate Manager. Our team quickly identified the problem and implemented a fix. Full functionality has been restored, and we are monitoring the situation to ensure continued stability.

We apologize for any inconvenience this may have caused and appreciate your understanding. If you have any questions, please feel free to contact us at support@rebill.com.
Posted Oct 12, 2024 - 10:00 UTC