The issue that caused service intermittency affecting access to the platform and payment links has been fully resolved. The platform is now operating normally.
Our team will continue monitoring to ensure full stability.
We appreciate your patience and understanding throughout this process.
If you need assistance, please don’t hesitate to reach out to us at support@rebill.com.
Posted Aug 26, 2025 - 16:47 UTC
Monitoring
Dear merchant,
The issue causing service intermittency affecting access to the platform and payment links has been mitigated. Our team has implemented the necessary adjustments and we are now monitoring closely to ensure full stability.
We appreciate your patience and understanding during this time.
If you experience any issues, please don’t hesitate to contact us at support@rebill.com.
Posted Aug 26, 2025 - 15:58 UTC
Investigating
Dear merchant,
We are currently experiencing a minor service intermittency that may affect access to the platform as well as payment links. Our team is already investigating the issue in order to restore normal operation as soon as possible.
We apologize for any inconvenience this may cause and appreciate your understanding.
If you need assistance, please don’t hesitate to reach out to us at support@rebill.com.
Posted Aug 26, 2025 - 13:48 UTC
This incident affected: Platform (Payment Service, Dashboard).