Intermittent webhook delivery delays

Incident Report for Rebill.com

Resolved

Resolved – June 26, 2026, 20:11 UTC

Outbound webhook delivery has been fully restored as of 20:11 UTC.
All events queued during the affected window (08:08 UTC to 20:11 UTC)
have been successfully delivered to merchant endpoints.

Payment and subscription processing were not affected at any point.
The impact was limited to the timing of webhook notifications, which
arrived with delays ranging from a few minutes up to several hours
for some events.

We apologize for the inconvenience this may have caused. If you
notice any missing notification on your end, please reach out to us
at support@rebill.com and we will trace it individually.
Posted Jun 26, 2026 - 20:37 UTC

Identified

Identified – June 26, 2026, 08:08 UTC

We have identified an issue affecting outbound webhook delivery to
merchant endpoints, starting at approximately 08:08 UTC today. Events
are being generated and queued correctly, but the delivery worker is
experiencing periods of reduced throughput, causing notifications to
arrive with delays.

Payment and subscription processing are operating normally on our
side. The impact is limited to the timing of webhook notifications.

Our engineering team is actively investigating and we will post the
next update as soon as we have more information.

We apologize for the inconvenience, and if you need assistance,
please reach out to us at support@rebill.com.
Posted Jun 26, 2026 - 20:36 UTC
This incident affected: Notifications (Webhooks).